Budget HDU6575

Problem Description
Avin’s company has many ongoing projects with different budgets. His company records the budgets using numbers rounded to 3 digits after the decimal place. However, the company is updating the system and all budgets will be rounded to 2 digits after the decimal place. For example, 1.004 will be rounded down
to 1.00 while 1.995 will be rounded up to 2.00. Avin wants to know the difference of the total budget caused by the update.

Input
The first line contains an integer n (1 ≤ n ≤ 1, 000). The second line contains n decimals, and the i-th decimal ai (0 ≤ ai ≤ 1e18) represents the budget of the i -th project. All decimals are rounded to 3 digits.

Output
Print the difference rounded to 3 digits…

Sample Input
1
1.001
1
0.999
2
1.001 0.999

Sample Output
-0.001
0.001
0.000
四舍五入取差值,若最后一位小于5,差值为最后一位,如果大于等于5,取值为10减去最后那个值

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
using namespace std;
string a[123456];
int main()
{
	int n;
	while(cin>>n)
	{
		double ans=0;
		for(int i=1;i<=n;i++)
		{
			cin>>a[i];
			int l=a[i].length();
			if(a[i][l-1]<='4')
			{
				ans-=((a[i][l-1]-'0')*1.0)/1000;
			}
			else
			{
				ans+=((10-(a[i][l-1]-'0'))*1.0)/1000;
			}
		}
		printf("%.3lf\n",ans);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值