Is It A Tree?(并查集有向图判断树)

添加链接描述
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

在这里插入图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
思路:
每输入两个点都判断一下,这两个点连接以后会不会成为环,换句话说就是,判断一下合并之前,这两个点是不是同一个爹,如果还没合并,就是同一个爹了,那合并之后肯定成环,就不符合树的定义了。
所有数合并之后,遍历一遍所有输入的数,看看他们是不是都有一个共同的爹,否则那也不是树。

AC完整代码
#include <iostream>
#include <algorithm>
#include <cmath>
#include <ctype.h>
#include <cstring>
#include <cstdio>
#include <sstream>
#include <cstdlib>
#include <iomanip>
#include <string>
#include <queue>
#include <map>
#define M 50005
#define ll long long
using namespace std;
const int maxn = 10000;
const int INF=0xfffffff;
const int maxx=200005;

using namespace std;

int f[maxn]={0},n,m,sum=0;
int vis[maxn];

//这里初始化,非常重要,数组里存的是自己数组下标的编号就好了
void init()
{
    int i;
    for(i=1;i<=maxn;i++)
        f[i]=i;
    return ;
}
//这是找爹的递归函数,不停的去找爹,直到找到祖宗为止,其实就是去找犯罪团伙的最高领导人,擒贼先擒王原则
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        //这里是路径压缩,每次在函数返回的时候,顺路把路上遇到的boss改为最后找的的祖宗的编号
        f[v]=getf(f[v]);//这里进行了路径压缩
        return f[v];
    }
}
//这里是合并两个子集的函数
void Merge(int v,int u)
{
    int t1,t2;//t1,t2分别为v和u的大boss,每次双方的会谈都必须是各自最高领导人
    t1=getf(v);
    t2=getf(u);
    if(t1!=t2)//判断两个结点是否在同一个集合中,即是否为同一个祖先
        f[t2]=t1;
    //靠左原则,左边变成右边的boss
    return;
}
int main()
{
    int flag=1,k=1;
    memset(vis,0,sizeof(vis));
    init();
    while(cin>>n>>m)
    {
        if(n<0&&m<0)
            break;
        if(n==0&&m==0)
        {
            int first=0;
            for(int i=1;i<maxn;i++)
            {
                if(vis[i])
                {
                    first=i;
                    break;
                }
            }
            for(int i=1;i<maxn;i++)
            {
                if(vis[i]&&first&&getf(first)!=getf(i))
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
                printf("Case %d is a tree.\n",k++);
            else
                printf("Case %d is not a tree.\n",k++);
            flag=1;
            init();
            memset(vis,0,sizeof(vis));
        }
        else
        {
            vis[n]=1;
            vis[m]=1;
            if(getf(n)==getf(m))
                flag=0;
            else
                Merge(n,m);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值