PAT 1135 Is It A Red-Black Tree

PAT 1135 Is It A Red-Black Tree

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
Figure1:
Figure1
Figure2:
在这里插入图片描述
Figure3:
在这里插入图片描述
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:
For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

题意:给出一棵树的先序遍历,判断该树是否为红黑树。

思路:根据题中给出的红黑树的定义:根节点为黑色;如果一个节点为红色,那么其子节点都为黑色;从根节点到所有叶节点的路径上黑色节点的个数相同。同时红黑树为BST,在先序遍历中找出第一个绝对值大于根节点的位置,即为左子树开始的位置,就可以递归构造出二叉树。之后通过函数judge,传递root和路径上黑色节点的个数x,递归地根据上面三点红黑树的特征进行判断即可。

AC代码:

#include <stdio.h>
#include <set>
#include <stdlib.h>
using namespace std;

struct Node{
    Node *left;
    Node *right;
    int data;
};
int a[40];

Node *create(int l,int r){
    if(l>r)
        return NULL;
    Node *root=new Node;
    root->data=a[l];
    int k;
    for(k=l+1;k<=r;k++){
        if(abs(a[k])>abs(a[l]))
            break;
    }
    root->left=create(l+1,k-1);
    root->right=create(k,r);
    return root;
}

set<int> s;
bool judge(Node *root,int x){
    if(root!=NULL){
        int Count;
        if(root->data>0)
            Count=1;
        else
            Count=0;
        if(root->left!=NULL&&root->data<0&&root->left->data<0)
            return false;
        if(root->right!=NULL&&root->data<0&&root->right->data<0)
            return false;
        if(!judge(root->left,x+Count))
            return false;
        if(!judge(root->right,x+Count))
            return false;
    }
    else{
        s.insert(x);
    }
    return true;
}

int main(){
    int k,n;
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        s.clear();
        scanf("%d",&n);
        for(int j=0;j<n;j++){
            scanf("%d",&a[j]);
        }
        Node *root=create(0,n-1);
        if(root->data<0)
            printf("No\n");
        else{
            bool flag=judge(root,0);
            if(flag==true&&s.size()==1)
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值