a+b系列问题

做一个a+b问题的合集,其实就是一个各种输入输出格式的汇总。

输入第一行是一个整数N,代表接下来N行会有N组样例输入,每组输出占一行。

sample input:
2
1 5
10 20

sample output:
6
30

#include<iostream>
using namespace std;
int main()
{
   
	int n;
	cin>>n;
	int a,b;
	int ans=0;
	for(nt i=0;i<n;i++)
	{
   
		cin>>a>>b;
		ans=a+b;
		cout<<ans<<endl;
	}
	return 0;
}

有多组样例输入,以0 0代表输入结束

sample input:
1 5
10 20
0 0

sample output:
6
30

#include<iostream>
#include<cstring>
#include<cstdio> 
using namespace std;
int main()
{
   
	int a,b,c[1000];
	int num=0;
	for(int i=0;i<1000;i++)
	{
   
		cin>>a>>b;
		if(a==0&&b==0)	break;
		c[i]=a+b;
		num++;
	}
	for(int i=0;i<num;i++)
	cout<<c[i]<<endl;
	return 0;
 }

计算a+b,有多组样例输入,每组输出占一行。

sample input:
1 5
10 20

sample output:
6
30

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
   </
  • 0
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值