H - Mondriaan's Dream(压状dp)

题目

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.
在这里插入图片描述
Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
Input在这里插入图片描述
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output
For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

解释

1,1代表横着放 0的下一行是1 代表竖着放.
status函数对第一行符合每个状态进行判断,则如果i的位置是1, i+1必须是1, 对第一行0不进行处理,
考虑到如果只有一行,但我们输出结果最后一行必定全为1, 结果是dp[i][(1<<m)-1],所以只有一行的时候不影响结果, 多行的第一行的0对初始化也也没有影响。
check函数检查now和pre状态是否不冲突,now代表第i行选取的状态, pre代表第i-1选取的状态,不冲突的情况是,1、now | pre == (1<<m)-1 (例如11011|00111 = 11111是相符合不冲突的);2、 当now情况中 j位置对应的二进制值为1, pre为0没关系,若pre也为1, 则pre与now的j+1位置的二进制必须为1。例如pre的j+1位置是0,我们本意是now这行j与j+1横着放,却成了j单独一块落单,不符合题意。
转移方程 dp[i][j] += dp[i-1][k]; dp[i][j]加上所有j符合k的dp[i-1][k],则是dp[i][j]对应的方案数。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
long long  dp[15][1<<12];
int n, m;
int status(int x){
    int i;
    for(i = 0; i < m; i++){
        if((x &(1<<i))){
            if(i == m-1) return 0;
            if((x &(1<<(i+1)))) i++;
            else return 0;
        }
    }
    return 1;
}
int check(int now, int pre){
    if((now|pre)!= ((1<<m)-1)) return 0;
    int j;
    for(j = 0; j < m; j++){
        if((now &(1<<j))){
            if((pre &(1<<j))){
                if(j == m-1) return 0;

                if(!(now &(1<<(j+1)))||!(pre &(1<<(j+1)))) return 0;
                else j++;
            }
        }
    }
    return 1;
}

int main(){
    int i, j, k;
    while(~scanf("%d %d", &n, &m)&&(n||m)){
        if((n&1) && (m&1)){
            printf("0\n");
            continue;
        }
        memset(dp, 0, sizeof(dp));
        if(n < m) swap(n, m);
        for(i = 0; i <= (1<<m)-1; i++){
            if(status(i))
                dp[0][i] = 1;
        }

        for(i = 1; i < n; i++){
            for(j = 0; j <= (1<<m)-1; j++){
                for(k = 0; k <= (1<<m)-1; k++)
                    if(check(j, k))
                        dp[i][j] += dp[i-1][k];
            }
        }

        printf("%lld\n", dp[n-1][(1<<m)-1]);

    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值