I - Best Reward(Manacher + 前缀数组)

题目

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones’ value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces’s value is greatest. Output this value.
Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v 1, v 2, …, v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor ‘a’ to ‘z’. representing the necklace. Different charactor representing different kinds of gemstones, and the value of ‘a’ is v 1, the value of ‘b’ is v 2, …, and so on. The length of the string is no more than 500000.

Output
Output a single Integer: the maximum value General Li can get from the necklace.
Sample Input

2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac

Sample Output

1
6

解释

利用Manacher算法得到扩充后的tmp数组每一位的Len长度(该位置对应的回文长度为2Len-1) ,例如acacac,第三个位置的a的Len值为3,对应的回文串为acaca,长度为32-1 = 5。在Manacher中添加pre与pos数组代表前i个字母、后i个字母分别是否为回文串(是为1, 非为0),仍用acacac, 例如pre[5](acaca),pre[3] (aca) 都为1,pos[3] (cac) = 1。而pre与pos其中的元素是否为1,则借助Manacher中的Len数组得到,对每一位已得到Len值的i来说, if(i-Len[i] == 0) pre[Len[i]-1] = 1; if(i+Len[i] == len+1) pos[Len[i]-1] = 1;(i位置对应回文串有Len[i]-1个字母(不算#号)) 此处len为tmp数组的最后一位的下标,或者说是原字符串长度*2+2。
已知pre与pos只需要i从1到length-1,看看前i个字母和后length-i个字母是否是回文串,有一个是就加上它对应的价值。而前多少个字母的价值使用num数组记录,所以有
if(pre[i]) //判断前i个是不是回文串
ans += num[i]; //加上前i个字母的总价值
if(pos[length-i]) //判断后length-i个是不是回文串
ans +=(num[length] - num[i]); //加上i后面的length-i个字母的总价值

再找出不断选出最大ans,得到结果。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 500010
using namespace std;
int val[27];
char str[maxn];
char tmp[maxn<<1];
int Len[maxn<<1], pre[maxn <<1], pos[maxn <<1], num[maxn];
int length;
void inint(){
    int i;
    tmp[0] = '@';
    for(i = 1; i <= length*2; i += 2){
        tmp[i] ='#';
        tmp[i+1] = str[i/2];
    }
    tmp[length*2+1] = '#';
    tmp[length*2+2] = '$';
}
void Manacher(int len){
    int mx = 0, po = 0, i = 0;
    for(i = 1; i <= len; i++){
        if(i < mx)
            Len[i] = min(Len[2*po-i], mx-i);
        else
            Len[i] = 1;
        while(tmp[i+Len[i]] == tmp[i-Len[i]])
            Len[i]++;
        if(i+Len[i] > mx){
                mx = i+Len[i];
                po = i;
        }
        if(i-Len[i] == 0) pre[Len[i]-1] = 1;
        if(i+Len[i] == len+1) pos[Len[i]-1] = 1;
    }

}
int main(){
    int t, i, j;
    scanf("%d", &t);
    while(t--){
        for(i = 0; i < 26; i++)
            scanf("%d", &val[i]);
        scanf("%s", str);
        length = strlen(str);
        inint();
        num[0] = 0;
        for(i = 1; i <= length; i++)
            num[i] = num[i-1] +val[str[i-1]-'a'];
        memset(pre, 0, sizeof(pre));
        memset(pos, 0, sizeof(pos));
        memset(Len, 0, sizeof(Len));
        Manacher(length*2+1);
        int ans, res = 0;
        for(i = 1; i < length; i++){
            ans = 0;
            if(pre[i]) ans += num[i];
            if(pos[length-i]) ans +=(num[length] - num[i]);
            res = max(ans, res);
        }
        printf("%d\n", res);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值