Zipper--记忆化搜索

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.
Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

这个题可以定义三个变量,分别对三个字符串下标进行标记,然后进行dfs,注意设置好dfs的结尾条件就行,这个题还有一个就是要进行记忆化,不然会超时,具体看代码。

#include<bits/stdc++.h>
using namespace std;

string a,b,c;
int wo,yao,meizi;
int ans;
int dp[205][205];
void dfs(int x,int y,int z)
{
	if(ans)return ;//剪枝 
	if(x==wo&&y==yao&&z==meizi){//结束条件 
		ans=1;//标记 
		return ;
	}
	if(dp[x][y])return ;// 如果搜索过,就 return  
	dp[x][y]=1;// dp标记,记忆搜索 
	if(x>wo||y>yao||z>meizi)return ;//越界 
	if(a[x]==c[z])dfs(x+1,y,z+1);//第一种情况 
	if(b[y]==c[z])dfs(x,y+1,z+1);//第二种情况 
}
int main()
{
	int T,k=1;
	cin>>T;
	while(T--)
	{
		cin>>a>>b>>c;
		wo=a.size();
		yao=b.size();
		meizi=c.size();
		if(meizi!=wo+yao){//一个小判断 
			printf("Data set %d: no\n",k++);
			continue;
		}
		ans=0;
		memset(dp,0,sizeof(dp));//多组输入,进行初始化 
		dfs(0,0,0);
		if(ans)printf("Data set %d: yes\n",k++);
		else printf("Data set %d: no\n",k++);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值