E - What Is Your Grade?

“Point, point, life of student!”

This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.

There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.

Note, only 1 student will get the score 95 when 3 students have solved 4 problems.

I wish you all can pass the exam!

Come on!

    Input
    Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p. 

A test case starting with a negative integer terminates the input and this test case should not to be processed.

    Output
    Output the scores of N students in N lines for each case, and there is a blank line after each case. 



    Sample Input
    4

5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

    Sample Output
    100

90
90
95

100

两个地方注意,每组样例后多一个换行,相同题数是取总数一半+5,不是第一个
(此代码不用sort排序)


#include"stdio.h"
#include"string.h"
#include"algorithm"
using namespace std;
struct ssq
{
	int x;
	char t[20];
	int fs;
}sq[1005];
int main()
{
	int n;
	while(~scanf("%d",&n)&&n>0)
	{
		int s[10],ss[10];
		memset(s,0,sizeof(s));
		memset(ss,0,sizeof(ss));
		for(int i=0;i<n;i++)
		{
			scanf("%d %s",&sq[i].x,sq[i].t);
			s[sq[i].x]++;//记录做完题数对应数量人数 
			sq[i].fs=0;//分数归0 
		}
		for(int i=0;i<n;i++)//遍历结构体 
		{
			if(sq[i].x==5)//特殊处理5题 
			sq[i].fs=100;
			else if(sq[i].x==0)//特殊处理0题 
			sq[i].fs=50;
			else
			{	
				if(s[sq[i].x]==1)//特殊处理做对1题 
				sq[i].fs=(sq[i].x*10+55);
				else if(ss[sq[i].x]<s[sq[i].x]/2&&sq[i].fs==0)//找出本题数中最小耗时
				{
					int v=i;//记录位置当前
					for(int j=0;j<n;j++)
					{
						if(sq[j].fs==0&&sq[j].x==sq[v].x&&strcmp(sq[j].t,sq[v].t)<0)//更改最小耗时位置
						v=j;
					}
					ss[sq[i].x]++;//记录已经找出的最小耗时人数
					sq[v].fs=55+sq[v].x*10;//更改分数
				}
			}	
		}
		for(int i=0;i<n;i++)
		{
			if(sq[i].fs!=0)
			printf("%d\n",sq[i].fs);
			else
			printf("%d\n",sq[i].x*10+50);//没有分值的赋基础分值 
		}
		printf("\n");
		
	}
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值