POJ-3259 Wormholes 虫洞(SPFA、Floyd判断负权环)

这有一个虫洞,可以送你到POJ3259

  • 请看题:

                                             Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 73733 Accepted: 27416

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

 

  • 虫洞真是一个神奇的玩意,看了半天没看明白题的意思~_~
  • 据说虫洞是一个单向路,能够把你传送到目的地,还会使时间倒流
  • 农夫约翰有F个农场,每个农场有N块地,其间有M条路,W条时光隧道(时间倒流)
  • 问是否可能回到过去
  • 咱也想整个虫洞玩玩,如果能回到过去,一定早早地就学习算法,就不会像现在一样啥都不会了~_~
  • 其实就是判断一下路径里面有没有负权环如果有的话,我每绕一圈最短路就会再短一点,绕着绕着就可以耗费0时间回来了,即满足题意,可以回到过去
  • Dijkstra是没法做有负环的最短路问题的。。。
  • 这道题的数据量比较可观,暴力的Floyd是可以解决的,就是要注意输入输出以及最小值的情况,正常我跑了1704ms  好险,不正常一点就会TLE;
  • 另一个方法就是解决负权环专用的SPFA算法,这个我也是刚学的。。。
  • 这有一个blog,有助于理解SPFA的思想及手动实现

大佬就是大佬,tql,Orz

奉上本人卑微的代码:

  • Floyd(暴力一号):

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int inf=0x3f3f3f3f;
int map[505][505];
int n,m;
int floyd(){
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++)
				if(map[i][j]>map[i][k]+map[k][j]) 
					map[i][j]=map[i][k]+map[k][j];
				//map[i][j]=min(map[i][j],map[i][k]+map[k][j]);谁也没想到 min居然比if慢 
			if(map[i][i]<0)
				return 1;
		}
	return 0;
}
int main()
{
	int t,k;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&n,&m,&k);
		memset(map,inf,sizeof(map));
		for(int i=1;i<=n;i++)
			map[i][i]=0;
		int x,y,z;
		for(int i=1;i<=m;i++){
			scanf("%d%d%d",&x,&y,&z);
			if(map[x][y]>z)
				map[x][y]=map[y][x]=z;
		}
		for(int i=1;i<=k;i++){
			cin>>x>>y>>z;
			map[x][y]=-z;
		}
		if(floyd())printf("YES\n");
		else printf("NO\n");
	}
	return 0;
 } 

 

  • SPFA(更快更高大上):

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

const int inf=0x3f3f3f3f;
const int mm=5210;
int cnt=0;;
int dis[mm],head[mm],num[mm];//num[i] 记录该点进入队列的次数 
int book[mm];
int n,m,w;

struct node{
	int x,y,z,next;
}pp[mm];

void add(int x,int y,int z){//搭建静态链表,存入数据 
	pp[cnt].x=x;
	pp[cnt].y=y;
	pp[cnt].z=z;
	pp[cnt].next=head[x];
	head[x]=cnt++;
}

int spfa(){//板子 
	memset(book,0,sizeof(book));
	memset(num,0,sizeof(num));
	queue<int>q;
	
	book[1]=1;
	dis[1]=0;
	q.push(1);
	num[1]++;
	while(!q.empty()){
		int p=q.front();
		q.pop();
		book[p]=0;//该点没在队列中 
		for(int i=head[p];i!=-1;i=pp[i].next){//枚举链表中的所有走法 
			int t=pp[i].y;
			if(dis[t]>dis[p]+pp[i].z){
				dis[t]=dis[p]+pp[i].z;//松弛 
				if(book[t]==0){ 
					q.push(t);
					book[t]=1;//加入队列 标记 
					num[t]++;
					if(num[t]>n)// 进入队列的次数超过n  证明存在负环 
						return 1;
				}
			}
		}
	}
	return 0;
}

int main()
{
	int t,a,b,c;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&n,&m,&w);
		cnt=0;
		memset(head,-1,sizeof(head));//静态链表易忘!!! 
		memset(dis,inf,sizeof(dis));
		for(int i=1;i<=m;i++){
			scanf("%d%d%d",&a,&b,&c);
			add(a,b,c);
			add(b,a,c);
		}
		for(int i=1;i<=w;i++){//虫洞的时间倒流,存入负值 
			scanf("%d%d%d",&a,&b,&c);
			add(a,b,-c);
		}
		if(spfa())
			printf("YES\n");
		else printf("NO\n"); 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值