PAT 1078 素数

题目

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

给定两个数,第一个数是Size,第二个数是题目下面会输入的数字个数,要求Size如果不是素数则要变成离他最近且不小于他的一个素数。然后进行Hash,出现冲突的话使用二次方探查法,如果无法解决冲突则输出“-”,否则输出该数字在Hash表中的位置.

代码和思路

  1. 考察素数的部分就是对素数的判断,前面已经写的很详尽了,就是注意对1的特判就行
  2. 二次方探查法,指的是当Hash[index]冲突的时候,让index变为 index + 12, index + 22, index + 32,但是要注意后面的平方数不超过Size
#include<cstdio>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn = 100010;

int hashtable[maxn];
int m, n;

bool isPrime(int m) {
	if (m <= 1) return false;
	for (int i = 2; i <= sqrt(m); i++) {
		if (m % i == 0)
			return false;
	}
	return true;
}

void changePrime(int &m) {
	while (!isPrime(m)) {
		m++;
	}
}

int main() {
	int index;
	int num;
	bool flag;
	fill(hashtable, hashtable + maxn, 0);
	scanf("%d %d", &m, &n);
	flag = isPrime(m);
	if (!flag) {
		changePrime(m);
	}
	for (int i = 0; i < n; i++) {
		scanf("%d", &num);
		index = num % m;
		if (hashtable[index] == 0) {
			hashtable[index]++;
			printf("%d", index);
		}
		else {
			int step;
			for (step = 1; step < m; step++) {
				index = (num + step * step) % m;
				if (hashtable[index] == 0) {
					hashtable[index]++;
					printf("%d", index);
					break;
				}
			}
      if (step == m) printf("-");
		}
		if (i != n - 1) printf(" ");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值