HDU 1754---I Hate It(线段树-单点更新)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1754
Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output
对于每一次询问操作,在一行里面输出最高成绩。

Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output
5
6
5
9

思路:
求的是区间内的最大值,只用修改一下模板的递归的条件

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <string>
#include <sstream>
#include <stack>
#include <queue>
#include <map>

using namespace std;
const int inf=0x3f3f3f3f;
const int MAX=2e5+5;
typedef long long ll;
int m, n;
ll num[MAX], tree[MAX*4];

void build(int p, int l, int r)
{
	if(l == r) {
		tree[p] = num[l];
		return ;
	}
	int mid = (l + r) / 2;
	build(p*2, l, mid);
	build(p*2+1, mid+1, r);
	tree[p] = max(tree[p*2], tree[p*2+1]);
}

void update(int p, int l, int r, int x, int y)
{
	if(x < l || x > r) {
		return ;
	}
	if(l == r && l == x) {
		tree[p] = y;
		return ;
	}
	int mid = (l + r) / 2;
	update(p*2, l, mid, x, y);
	update(p*2+1, mid+1, r, x, y);
	tree[p] = max(tree[p*2], tree[p*2+1]);
}

ll query(int p, int l, int r, int x, int y)
{
	if(l > y || r < x) {
		return 0;	
	}
	if(x <= l && r <= y) {
		return tree[p];	
	}
	int mid = (l + r) / 2;
	ll sum = 0;
	sum = max(sum, query(p*2, l, mid, x, y));
	sum = max(sum, query(p*2+1, mid+1, r, x, y));
	return sum;	
}

int main()
{
	ios::sync_with_stdio(false);
	while(~ (scanf("%d%d", &n, &m))) {
		for(int i = 1; i <= n; i++) {
			scanf("%d", &num[i]);
		}
		build(1,1,n);
		int a, b;
		char temp;
		for(int i = 1; i <= m; i++) {
			scanf("%*c%c%d%d", &temp, &a, &b);
			if(temp == 'Q') {
				printf("%lld\n", query(1, 1, n, a, b));
			}
			if(temp == 'U') {
				update(1, 1, n, a, b);
			}
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值