POJ 3641: 伪素数

POJ 3641: Pseudoprime numbers


——伪素数
原题传送门

Description

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p).
That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a.
(And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given p and a, determine whether or not p is a base-a pseudoprime.

Data

Input
Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.
Output
For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample output
no
no
yes
no
yes
yes

2<p≤1000000000 1<a<p

思路

一道关于伪素数的模板题.

伪素数

费马小定理

了解一下
这里不再详细介绍,可以查阅其他博主的资料.?

简单介绍一下思路
对于每一个正整数x:

  • 先判断x是否为质数,是就输出no(Sample 1)
  • 再用快速幂求出k=pow(a,p)%p,判断k是否等于a即可.

//顺便说一下,1105好像是个Carmicheal数.

Code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;
ll a,p;
bool prime(ll x)
{
	if (x==0||x==1) return false;
	for (int i=2;i*i<=x;i++)
		if (x%i==0) return false;
	return true;
}
ll qpow(ll a,ll b,ll p)
{
	ll ans=1;
	while (b>0)
	{
		if (b&1) ans=ans*a%p;
		b>>=1;	
		a=a*a%p;
	} 
	return ans;
}
int main()
{
	while (~scanf("%lld%lld",&p,&a))
	{
		if (p==0||a==0) break;
		if (prime(p))
		{
			printf("no\n");
			continue;
		}
		ll k=qpow(a,p,p);
		if (k==a) printf("yes\n");
		else printf("no\n");
	}
	return 0;
}

感谢奆老关注 qwq ?

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值