PAT甲级A1005 Spell It Right (20分) (题目+ 代码 + 详细注释)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤1e​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

//题意:对一个数组的每一位求和,并把每一位数字转换成相应的英文单词。由于最大数据是1e100,所以用数组存取每一位

#include<cstdio>
#include<cstring>
char mp[][10] = { "zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine" };          //制表,下标与字符串对应

int main() {
    char* ans[5];          //ans储存数字对应的字符串,因为sum的最大值为9 * 100 = 900,才3位数,开大点给个5即可
    char s[105]; 
    scanf("%s", s);         //读取数字
    int len = strlen(s);
    int sum = 0;
    for (int i = 0; i < len; i++)
        sum += s[i] - '0';          //对每一位求和
    int t = 0;                     //t表示sum的位数
    do {                          //用do-while是为了防止有sum = 0的情况
        ans[t++] = mp[sum % 10];
        sum /= 10;
    } while (sum);
    while (t--)             //逆序输出ans数组,因为得到ans时是从sum的低位开始的
        printf("%s%s", ans[t], t ? " " : "");    //最后一位没有空格,可用三元运算符控制

    return 0;
}

//本题是 “PAT乙级1002写出这个数"的翻版,感兴趣的可以点开看看!!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值