筛法+前缀和

A pretty straight forward task, calculate the number of primes between 2 integers.

Given 2 integers A ≤ B < 10
5 what’s the number of primes in range from A to B inclusive.

Note: A prime number is a positive integer greater than 1 and is divisible by 1 and itself only. For N to be prime it is enough to test the divisibility of numbers less than or equal to square root of N.

    Input
    
  
   As many as 1000 lines, each line contains 2 integers A and B separated by a space. Input is terminated when A = B = -1 (Do not process this line).
  

    Output
    
  
   For every line in input – except for the last line where A = B = -1 - print the number of prime numbers between A and B inclusive.
  

    Sample Input
    0 9999

1 5
-1 -1

    Sample Output
    1229

3

#include<iostream>
#include<algorithm>
using namespace std;

const int N=100010;

int st[N];

int main()
{
	for(int i=2;i<N;i++)
	{
		if(!st[i])
		{
			for(int j=i+i;j<N;j+=i)
				st[j]=1;
		}
	}

st[0]=0;
	st[1]=0;
	for(int i=2;i<N;i++)
	{
		if(st[i]==0) st[i]=1;
		else st[i]=0;

	st[i]+=st[i-1];
	}

int a,b;
	while(cin>>a>>b)
	{
		if(a==-1&&b==-1)break;
		
		cout<<st[b]-st[a-1]<<endl;
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值