Monthly Expense(二分)

Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2… N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:
给出农夫在n天中每天的花费,要求把这n天分成连续的m组,要求各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。
思路:
经典的二分题目,找到答案所在的区间 [ l , r ] 之间,然后二分区间
bet=( l + r )/ 2,然后用check()函数检验 bet 是否符合题目要求,时间复杂度是log(n)。把所有天数的总花费作为上界 r(相当于把n天都分作1组),把n天中花费最多的那一天的花费作为下界 l(相当于把n天分为n组),那么要求的值必然在 [ l , r ] 范围内。

完整代码:

#include<iostream>
using namespace std;
const int inf = 0x3f3f3f3f;
int n,m;
int a[100005];
int check(int x)        //查询判断是否为所需
{
    int c=1;
    int ans=a[0];
    if(ans>x)
    {
        return 0;
    }
    for(int i=1;i<n;i++)
    {
        if(a[i]>x)
        {
            return 0;
        }
        if(ans+a[i]<=x)
        {
            ans+=a[i];
        }
        else
        {
            c++;
            ans=a[i];
        }
    }
    if(c>m)
    {
        return 0;
    }
    else
    {
        return 1;
    }
}

void binary()       //二分
{
    int l=0,r=inf;
    while(r-l>1)
    {
        int bet =(l+r)/2;
        if(check(bet))
        {
            r=bet;
        }
        else
        {
            l=bet;
        }
    }
    cout<<r<<endl;
}

int main()
{
    cin>>n>>m;
    for(int i=0;i<n;i++)
    {
        cin>>a[i];
    }
    binary();
    return 0;
}
  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值