A Bug‘s Life POJ - 2492(并查集)

A Bug’s Life

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
数据量很大,建议用scanf输入

题意:
此题的题意是分别给出多组数据,每组数据是不同的性别,让你分析是否给出的数据中存在相同的性别,输出指定的语句。

思路:
此题与食物链的题型差不多。就这道题而言,很明显昆虫之间就两种关系,同性和异性,我们分别标记为0 和 1,用d数组存放,具体点说就是d[i] == 0 表示 i 跟 p[i] 是同性,反之异性。

代码:
代码一:

#include<iostream>
#include<cstdio>

using namespace std;

const int N = 2021;
int p[N],d[N];

int find(int x)
{
    if(p[x]!=x)
    {
        int u=find(p[x]);
        d[x]+=d[p[x]];
        p[x]=u;
    }
    return p[x];
}

int main()
{   
    int t;
    scanf("%d",&t);
    int ans=1;
    while(t--)
    {
        memset(p,0,sizeof(p));
        memset(d,0,sizeof(d));
        
        int n,m;
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++) p[i]=i;
        
        bool flag=true;
        while(m--)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            int px=find(x), py=find(y);
            if(px==py && (d[x]-d[y]-1)%2) flag=false;
            else
            {
                p[px]=py;
                d[px]=d[y]-d[x]+1;
            }
        }
        
        if(flag) printf("Scenario #%d:\nNo suspicious bugs found!\n\n",ans++);
        else printf("Scenario #%d:\nSuspicious bugs found!\n\n",ans++);
    }
    
    return 0;
}

代码二:

#include<iostream>
#include<cstdio>

using namespace std;

const int N = 2021;
int p[N],d[N];

int find(int x)
{
    if(p[x]!=x)
    {
        int u=find(p[x]);
        d[x]+=d[p[x]];
        d[x]%=2;
        p[x]=u;
    }
    return p[x];
}

int main()
{   
    int t;
    scanf("%d",&t);
    int ans=1;
    while(t--)
    {
        memset(p,0,sizeof(p));
        memset(d,0,sizeof(d));
        
        int n,m;
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++) p[i]=i;
        
        bool flag=true;
        while(m--)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            int px=find(x), py=find(y);
            if(px==py && d[x]==d[y]) flag=false;
            else
            {
                p[px]=py;
                d[px]=(d[y]-d[x]+1)%2;
            }
        }
        
        if(flag) printf("Scenario #%d:\nNo suspicious bugs found!\n\n",ans++);
        else printf("Scenario #%d:\nSuspicious bugs found!\n\n",ans++);
    }
    
    return 0;
}

代码三:

#include<iostream>
#include<cstdio>

using namespace std;

const int N = 2021;
int p[N],d[N];

int find(int x)
{
    if(p[x]!=x)
    {
        int u=find(p[x]);
        d[x]+=d[p[x]];
        d[x]%=2;
        p[x]=u;
    }
    return p[x];
}

int main()
{   
    int t;
    scanf("%d",&t);
    int ans=1;
    while(t--)
    {
        memset(p,0,sizeof(p));
        memset(d,0,sizeof(d));
        
        int n,m;
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++) p[i]=i;
        
        bool flag=true;
        while(m--)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            int px=find(x), py=find(y);
            if(px==py && d[x]==d[y]) flag=false;
            else
            {
                p[px]=py;
                d[px]=(d[y]-d[x]+1+2)%2;	// +2是怕d[y]-d[x]时出现负数
            }
        }
        
        if(flag) printf("Scenario #%d:\nNo suspicious bugs found!\n\n",ans++);
        else printf("Scenario #%d:\nSuspicious bugs found!\n\n",ans++);
    }
    
    return 0;
}

原题链接:
vjudge
poj

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值