PTA-链表处理(1074)

1074 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

思路

这道题还是比较难的我觉得,第一次做就做满分并不容易。
首先创建静态链表并排序,创建之后开始准备输出工作,every K elements说明是每k个逆序,所以要分成n/k组,最后特判一下是不是最后一个元素,记得单独输出-1。

#include<bits/stdc++.h>
using namespace std;
struct node{
	int add,data,next;
	int order;
}; 
const int maxx=100010;
node ans[maxx];
bool cmp(node a,node b){
	return a.order<b.order;
}
int main(){
	for(int i=0;i<maxx;i++){
		ans[i].order=maxx+1;
	}
	int first,n,m;
	cin>>first>>n>>m;
	for(int i=0;i<n;i++){
		int add;
		cin>>add;
		cin>>ans[add].data>>ans[add].next;
		ans[add].add=add;
	}
	int nextp=first;
	int cnt=0;
	while(nextp!=-1){
		ans[nextp].order=cnt++;
		nextp=ans[nextp].next;
	}
	n=cnt;
	sort(ans,ans+maxx,cmp);
	for(int i=0;i<n/m;i++){
		for(int j=(i+1)*m-1;j>i*m;j--){
			printf("%05d %d %05d\n",ans[j].add,ans[j].data,ans[j-1].add);
		}
		printf("%05d %d ",ans[i*m].add,ans[i*m].data);
		if(i<n/m-1){
			printf("%05d\n",ans[(i+2)*m-1].add);
		} else{
			if(n%m==0) printf("-1\n");
			else{
				printf("%05d\n",ans[(i+1)*m].add);
				for(int j=n/m*m;j<n;j++){
					printf("%05d %d ",ans[j].add,ans[j].data);
					if(j!=n-1) printf("%05d\n",ans[j+1].add);
					else printf("-1\n");
				}
			} 
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值