Digit Generator UVA - 1583

​   For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N, we call N a generator of M.

​   For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256. Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

​   You are to write a program to find the smallest generator of the given integer.

Input

​   Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N, 1 ≤ N ≤ 100, 000.

Output

​   Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

HINT

​   题目的意思很明显,要求满足256 (= 245 + 2 + 4 + 5)形式的整数。一个n位整数假设每一位都是9,那么要求的数里面可能的最小的数就是N-9*n;(其中N是给定的数字)。

Accepted

#include<stdio.h>

int min(int t)			//求出给定数字的位数
{					   //也可以用循环来求出
    if(t<10)return 1;
    if(t<100)return 2;
    if(t<1000)return 3;
    if(t<10000)return 4;
    if(t<100000)return 5;
    if(t<1000000)return 6;
}

int mm(int t)		//求出每一位数字的和
{
    int k=0;
    while(t)
    {
        k+=t%10;
        t/=10;
    }
    return k;
}

int main()
{
    int sum;
    scanf("%d",&sum);
    while(sum--)
    {
        int flag=0;
        int t;
        scanf("%d",&t);
        int k=min(t);
        int minst=t-k*9;
        minst=minst>0?minst:1;
        for(minst;minst<t;minst++)
        {
            if((minst+mm(minst))==t)
            {
                printf("%d\n",minst);
                continue;
            }
        }
        printf("0\n");

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值