Ananagrams UVA - 156

  Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

  Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

  Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

  Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

  Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
#

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon

HINT

  代码和紫皮书上的一样,大体上的思路就是把每一个单词分别存在数组中,然后这个单词转化为全小写的存到map中,每存一次,键值加一。输入完毕之后将再数组中的单词转化为小写的看map中的键值是否为1,如果是将将这个单词存起来。最后排序输出。

Accepted

#include<algorithm>
#include <iostream>
#include<sstream>
#include<map>
#include<string>
#include<vector>

using namespace std;
map<string, int>cnt;
vector<string>words;

string reform(string s)
{
	for (int i = 0;i < s.length();i++)
		s[i] = tolower(s[i]);			//将小写转化
	sort(s.begin(), s.end());			//重排
	return s;
}

int main()
{
	string s;
	while (cin>>s)
	{
		if (s[0] == '#')break;
		words.push_back(s);				//将单词存入
		string r = reform(s);			//将转化过的单词存入map
		if (!cnt.count(r))cnt[r] = 0;
		cnt[r]++;						//如果如果单词已经有了,键值加一
	}
	vector<string>ans;					//用来存储目标单词
	for (int i = 0;i < words.size();i++)//但输入的每一单词转化后对比键值是否为1,也就是仅仅出现过一次
		if (cnt[reform(words[i])] == 1)ans.push_back(words[i]);//如果是将放入数组中
	sort(ans.begin(), ans.end());		//按照字典排序
	for (int i = 0;i < ans.size();i++)	//输出
		cout << ans[i] << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值