POJ - 3617 Best Cow Line(贪心)

8 篇文章 0 订阅

《挑战程序设计》里的一题。
问题描述

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input
* Line 1: A single integer: N
* Lines 2…N+1: Line i+1 contains a single initial (‘A’…‘Z’) of the cow in the ith position in the original line

Output
The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’…‘Z’) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

分析:

这个题目啊,贪心咯
不断取s的开头和末尾中较小的一个字符放到T的末尾
那如果开头和末尾字符一样呢?我们希望能够尽早使用更小的字符,所以就要比较下一个字符的大小,下一个字符也可能相同,则范围缩小一下继续判断,直到找到较小的字符。

但是回到这题的输入输出格式啊!呵呵!输入咋输?? 怎样让一个个字符回车输入,调了半天没成功。找别人题解——使用的是scanf(" %c",&c),这里多了个空格,这个空格就是为了缓解回输入回车带来的尴尬。ok,解决了输入,那么输出呢?每80个字符下一行,这个也调了半天,最后终于a过去了。

代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 2000+5;
char s[maxn];

int main()
{
	int N;
	while(scanf("%d",&N)!=EOF)
	{
		for(int i=0; i<N; i++)
		{
			scanf(" %c",&s[i]);
		}
		int a = 0, b = N - 1;
		int k = 0;
		while(a <= b)
		{
			bool ok = false;
			for(int i=0; a+i <= b; i++)
			{
				if(s[a+i] < s[b-i])
				{
					ok = true;
					break;
				}
				else if(s[a+i] > s[b-i])
				{
					ok = false;
					break;
				}
			}
			if(ok) putchar(s[a++]);
			else putchar(s[b--]);
			k++;
			if(k == 80){  
                printf("\n");  
                k = 0;  
            }     
		}
		printf("\n");
	}
	return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值