A1054 The Dominant Color (20 分)PAT (Advanced Level) Practice甲级题解C++【map的使用】

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

一开始是打算用结构体来存储每个颜色名和出现次数的,但后来发现直接用map矩阵来存储即可,能够更快的定位到每一个颜色名对应的出现次数,如果用结构体的话每次找某一颜色的次数都需要进行一次遍历,最后会导致运行超时。(然后做的时候竟然漏掉了出现次数必须超过一半的要求,而是直接想当然地输出了最大值,结果又超时了。。。)

代码如下:

#include<iostream>
#include<map>
using namespace std;
int main()
{
    int n,m;
    cin>>m>>n;
    int half=m*n/2;
    map<int,int> color;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++){
            int temp;
            cin>>temp;
            color[temp]++;
            if(color[temp]>half){
                cout<<temp<<endl;
                return 0;
            }
        }
    return 0;
}

运行结果如下:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值