A1138 Postorder Traversal(25分)PAT 甲级(Advanced Level) Practice(C++)满分题解【前中后序树的遍历】

这是一个关于数据结构的问题,具体涉及二叉树的构造和遍历。给定一棵所有键都是不同正整数的二叉树的前序和中序遍历序列,你需要找出后序遍历序列的第一个数字。提供的C++代码实现了这一功能,通过递归方式重建二叉树并输出后序遍历的第一个数。输入包括一个整数N表示节点数量,以及两行分别表示前序和中序遍历的整数序列。样例输入为7个节点的树,输出为后序遍历的第一个数字3。
摘要由CSDN通过智能技术生成

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

代码如下:

#include<bits/stdc++.h>
using namespace std;
//给出前序和中序序列,输出后序遍历的第一个number
int n;
vector<int> preorder,inorder;
bool first=true;
void postorder(int root,int start,int end)
{
    if(start>end||first==false)return;
    int i=start;
    while(preorder[root]!=inorder[i])i++;
    postorder(root+1,start,i-1);
    postorder(root+i-start+1,i+1,end);
    if(first){
        printf("%d\n",preorder[root]);
        first=false;
    }
}
int main()
{
    cin>>n;
    preorder.resize(n);
    inorder.resize(n);
    for(int i=0;i<n;i++)
        cin>>preorder[i];
    for(int i=0;i<n;i++)
        cin>>inorder[i];
    postorder(0,0,n-1);
    return 0;
}

运行结果如下:

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值