A1077 Kuchiguse(20分)PAT 甲级(Advanced Level) Practice(C++)满分题解【字符串】

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

题意分析:

这题还算比较简单,就是从后往前遍历找出所有字符串句子的相同部分,然后反转后输出,唯一要注意的点就是在输入字符串时,直接用cin是没有办法读入空格的,所以会出现不会输入所有字符串的情况,所以要用getline(cin,str),不过由于前面用cin输入了一个n,所以要用cin.ignore(1)忽略掉前一个cin遗留下的空格。

代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n,len=300;
	cin >> n;
	cin.ignore(1);
	vector<string> sentence(n);
	for (int k = 0; k < n; k++) {
		getline(cin,sentence[k]);
		len = min(len, (int)sentence[k].length());
	}
	string res = "";
	int i = 1;
	bool flag = true;//有口音
	while (i!=len+1&&flag)
	{
		int j;
		char c = sentence[0][sentence[0].length()-i];
		for (j = 1; j < n; j++) {
			if (sentence[j][sentence[j].length() - i] != c)
				break;
		}
		i++;
		if (j == n) {//每一个句子都有该字符
			flag = true;
			res += c;
		}
		else flag = false;
	}
	reverse(res.begin(), res.end());
	if (res == "")cout << "nai" << endl;
	else cout << res << endl;
	return 0;
}

运行结果如下:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值