Given any string of N (≥5) characters, you are asked to form the characters into the shape of U
. For example, helloworld
can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U
to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor
核心: n1<=n2时取最大n1 且 len-n2为偶数
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String word = sc.next();
int len=word.length();
int n2=3;
int n1=(len-n2)/2;
while((len-n2)%2!=0||n1>=n2) {
n2++;
n1=(len-n2)/2;
}
for(int i=0;i<n1;i++) {
System.out.println(word.charAt(i)+" ".repeat(n2-2)+word.charAt(len-i-1));
}
for(int i=0;i<n2;i++) {
System.out.print(word.charAt(n1+i));
}
System.out.println();
}
}