1037 Magic Coupon
分数 25
作者 CHEN, Yue
单位 浙江大学
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
* 题目意思,给出n种物品,每种物品有t件,t可取任意整数,意思t可以取负;
* 给出m种价格,价格可以取任意整数,意思价格可以取负;
* 每次选择一件物品及一个价格,将选择的物品对应的数量和选择的价格相乘,得到总价值。
* 要求最大的价值。可以想到正选正,负选负,这样可以得到最大的价值。
* 所以将商品数组和价格数组进行排序,在、从头尾进行两次遍历,当两个数的符号相同的时候,
* 就可以相乘,然后加起来。
*
* 具体看代码实现:
/**
* 题目意思,给出n种物品,每种物品有t件,t可取任意整数,意思t可以取负;
* 给出m种价格,价格可以取任意整数,意思价格可以取负;
* 每次选择一件物品及一个价格,将选择的物品对应的数量和选择的价格相乘,得到总价值。
* 要求最大的价值。可以想到正选正,负选负,这样可以得到最大的价值。
* 所以将商品数组和价格数组进行排序,在、从头尾进行两次遍历,当两个数的符号相同的时候,
* 就可以相乘,然后加起来。
*
* 具体看代码实现:
*/
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long LL;
const int N = 1e5+10;
int w[N], v[N];
int main()
{
int n, m;
cin >> n;
for(int i=0; i<n; ++i) cin >> w[i];
cin >> m;
for(int i=0; i<m; ++i) cin >> v[i];
sort(w, w+n), sort(v, v+m);
LL res = 0;
for(int i=0; i<n && i<m; ++i)
{
if(w[i] < 0 && (LL)w[i] * v[i] > 0)
res += (LL)w[i] * v[i];
else
break;
}
for(int i=n-1, j=m-1; i>=0 && j>=0; --i, --j)
{
if(w[i] > 0 && (LL)w[i] * v[j] > 0)
res += (LL)w[i] * v[j];
else
break;
}
cout << res << endl;
return 0;
}