PAT (Advanced Level) Practice 1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N ( ≤ 1 0 4 ) N (≤10^4) N(104), the total number of users, K ( ≤ 5 ) K (≤5) K(5), the total number of problems, and M ( ≤ 1 0 5 ) M (≤10^5) M(105), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N N N, and the problem id’s are from 1 to K K K. The next line contains K K K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for thei-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

思路

  • 没提交记录为-2,提交了没通过编译记录为-1, 通过了编译拿了0分记录为0
  • 记录每道题得分的最大值,所以每一次取原来值和新值的最大值
  • 利用status来记录是否有通过了编译的提交
  • 注意: sort之后顺序改变了.但是status没有变化,要用序号(v[i][K+1])来确定

AC code

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int N,K,M;
int p[5];
bool cmp(const vector<int>& a,const vector<int>& b){
    if(a[K]!=b[K]) return a[K]>b[K];
    int cnta=0,cntb=0;
    for(int i=0;i<K;i++){
        if(a[i]==p[i]) cnta++;
        if(b[i]==p[i]) cntb++;
    }
    if(cnta!=cntb) return cnta>cntb;
    return a[K+1]<b[K+1];
}
int main(){
    scanf("%d %d %d",&N,&K,&M);
    for(int i=0;i<K;i++){
        scanf("%d",&p[i]);
    }
    vector<vector<int> >v(N,vector<int>(K+2,-2));   //第K+1项是总分,-1代表编译不通过,-2代表没提交,第K+2项是id
    vector<bool> status(N,false);   //每个选手是否可以被输出
    int uid,pid,score;
    for(int i=0;i<M;i++){
        scanf("%d %d %d",&uid,&pid,&score);
        if(score>=0) status[uid-1]=true;
        v[uid-1][pid-1] = max(v[uid-1][pid-1],score);
    }
    for(int i=0;i<N;i++){
        v[i][K]=0;
        v[i][K+1]=i+1;
        for(int j=0;j<K;j++){
            if(v[i][j]>0) v[i][K]+=v[i][j];
        }
    }
    sort(v.begin(),v.end(),cmp);
    int idx=1,cnt=1,sum=v[0][K];
    for(int i=0;i<N;i++){
        if(status[v[i][K+1]-1]){
            if(sum!=v[i][K]){
                sum=v[i][K];
                idx = cnt;
            }
            cnt++;
            printf("%d %05d %d",idx,v[i][K+1],v[i][K]);
            for(int j=0;j<K;j++){
                if(v[i][j]>=0) printf(" %d",v[i][j]);
                else if(v[i][j]==-1) printf(" 0");
                else printf(" -");
            }
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值