PAT (Advanced Level) Practice 1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N ( ≤ 1 0 5 ) N (≤10^5) N(105), where the two addresses are the addresses of the first nodes of the two words, and N N N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

思路

  • 一开始做错的思路: 因为共用节点入度为2,而出度为1, 所以读取数据的时候留心入度为2的点就可以了, 假如-1的入度为2了, 说明有两个尾巴 自然没有公用后缀,直接输出-1

    • 错误的原因是: 题目里没有讲所有的点都在word1word2当中, 也就是存在没有关系的点, 这样的话就会有误, 我们一定要统计属于word1word2这两条链上的
    • 所以很容易想到把所有的点存下来, 遍历一遍word1, 把word1上的点标记为1, 后面遍历word2时有点的状态是1就可以认为在word1中出现过
  • 因为题目表示, 只有相同后缀才会合并使用, 非后缀相同不会合并, 所以只要有一个点是公用的,后面的都是公用的,共同组成共有后缀

AC code

#include<iostream>
using namespace std;
struct Node{
    int next;
    int status = 0;
}node[100005];
int main(){
    int head1,head2,tail,n,x,y;
    int ans=-1;
    char c;
    scanf("%d %d %d",&head1,&head2,&n);
    for(int i=0;i<n;i++){
        scanf("%d %c %d\n",&x,&c,&y);
        node[x].next = y;
    }
    for(int i=head1;i!=-1;i=node[i].next){
        node[i].status = 1;
    }
    for(int i=head2;i!=-1;i=node[i].next){
        if(node[i].status==1){
            ans = i;
            break;
        }
    }
    if(ans==-1) printf("-1");
    else printf("%05d",ans);  
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值