PAT (Advanced Level) Practice 1095 Cars on Campus (30 分)

PAT (Advanced Level) Practice 1095 Cars on Campus (30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N ( ≤ 1 0 4 ) N (≤10^4) N(104), the number of records, and K ( ≤ 8 × 1 0 4 ) K (≤8×10^4) K(8×104) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

tips

  • 大无语的一点是, 我将一小时当做24*60秒钟了, 纯纯憨包, 调了好久调不对
  • 借鉴柳神: 巧妙的一点是instatus即为1, outstatus记为-1, 这样计算里面车的总量只需要+=status
  • 先把所有的数据读入data, 排序筛选出有效的数据, 根据id排序, id相同按时间排序, 这样的情况下前后两个数据, 前面是in后面是out 并且两条数据id相同, 这样就是一组有效数据
  • 将有效数据按照时间排序(这里不按id字母序是因为后面要加入map,map本身是按照key的顺序来排的, key就是id)

AC code

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<vector>
using namespace std;
struct Log{
    int time;
    string id;
    int status;   //1表示in,-1表示out
};
bool cmp1(const Log& a,const Log& b){
    if(a.id!=b.id) return a.id<b.id;
    return a.time<b.time;
}
bool cmp2(const Log& a,const Log& b){
    return a.time<b.time;
}
int main(){
    int N,K,hh,mm,ss,time;
    string tmp;
    scanf("%d %d",&N,&K);
    getchar();  //接受'\n'
    vector<Log> data(N);
    for(int i=0;i<N;i++){
        cin>>data[i].id;
        scanf("%d:%d:%d",&hh,&mm,&ss);
        data[i].time=3600*hh+60*mm+ss;
        cin >> tmp;
        data[i].status=(tmp=="in")?1:-1;
        getchar();
    }
    vector<Log> validData;
    map<string,int> sum;
    int maxTime=-1;
    sort(data.begin(),data.end(),cmp1);
    for(int i=0;i<N-1;i++){
        if(data[i].id==data[i+1].id and data[i].status==1 and data[i+1].status==-1){
            validData.emplace_back(data[i]);
            validData.emplace_back(data[i+1]);
            sum[data[i].id]+=(data[i+1].time-data[i].time);
            maxTime = max(maxTime,sum[data[i].id]);
        }
    }
    sort(validData.begin(),validData.end(),cmp2);
    int cnt=0,cur=0;
    for(int i=0;i<K;i++){
        scanf("%d:%d:%d",&hh,&mm,&ss);
        time = 3600*hh+60*mm+ss;
        while(cur<validData.size()){
            if(validData[cur].time>time) break;
            cnt+=(validData[cur].status);
            cur++;
        }
        printf("%d\n",cnt);
    }
    for(auto& p:sum){
        if(p.second==maxTime){
            printf("%s ",p.first.c_str());
        }
    }
    printf("%02d:%02d:%02d\n",maxTime/(3600),maxTime%(3600)/60,maxTime%60);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值