Making the Grade

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A1 -  B1| + | A2 -  B2| + ... + | AN -  BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3
//dp[i][j]
//i代表数组的前i-1个元素已经调成单峰,现在正在进行第i个元素的调整.
//j代表当前第i个元素正在进行第j次调整(即第i个元素经过前j-1次调整可能还未达到最优)
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const int N = 2e3+5;
const ll inf = 1e15;
ll dp[N][N],a[N],b[N];
ll ab(ll x)
{
	return x>0?x:-x;
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i = 1; i <= n; i++)
	{
		scanf("%lld",&a[i]);
		b[i] = a[i];
	}
	sort(b + 1,b + 1 + n);
	for(int i = 1; i <= n; i++)
	{
        //对第i个元素的调整基于前i-1个元素的最优调整(即花费最少)
		ll minn = dp[i - 1][1];
		for(int j = 1; j <= n; j++)//依次遍历前i-1个元素达到最优调整所需要的花费,
		{
			minn = min(dp[i-1][j],minn);//找到最小花费
            dp[i][j] = minn+ab(a[i]-b[j]);//前i个元素的最小花费=前i-1个元素的最小花费+第i个                        元素的最小花费
           //单峰调整,后面的必须基于前面的进行调整
		//	printf("dp[%d][%d]=%d  %d %d %d\n",i,j,dp[i][j],a[i],b[j],minn);
		}
	}
	ll ans = inf;
	for(int i = 1; i <= n; i++)
		ans = min(ans,dp[n][i]);
	printf("%lld\n",ans);
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值