Making the Grade(优先队列/离散化dp)

Making the Grade(优先队列/离散化dp)

A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + … + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single integer elevation: Ai

Output

  • Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9
Sample Output
3

题意: 求把给定的序列变成单增或单减序列的最小代价

思路:
1. 优先队列
算出单增的最小代价,单减的最小代价,选其中的较小为答案(可能数据水的原因,只考虑单增就能过),单真么看的话,是不是觉得两遍for即可 ,但是这样是不对的,现在我们以变单增为例,说一下为什么不能用for,当前我们遇到5,3,以我当时的想法,是把3变5,但是还有另一种变法,将5变小,这就需要考虑5前面那个数是比3大还是比3小,以4,5,3为例,此时如果将5变3,4就也需要变,甚至更之前的也要变,所以我们将5变4,3变4,即变为4,4,4,这两种的代价虽是一样的,但会影响后续变化的代价,如5,3,4,如果用第一种,此时这个4就需在变,而用第二种就无需在变,所以单用for是不可以的

2.离散化dp
dp[i][j]表示前i个数在最大值为j的情况下的代价,为使后面的代价更小应该让最大值 j 和dp最小。其转移方程为x=min(x,dp[i-1][j]);
dp[i][j]=abs(a[i]-b[j])+x;

AC代码:

优先队列

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int a[2100],n;
int main()
{
	priority_queue<int>q;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	scanf("%d",&a[i]);
	int ans=0;
	for(int i=0;i<n;i++)
	{
		q.push(a[i]);
		if(a[i]<q.top())
		{
			ans+=q.top()-a[i];
			q.pop();
			q.push(a[i]);
		}
	}
	printf("%d\n",ans);
	return 0;
}

离散化dp

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[2100],b[2100],dp[2100][2100];
int main()
{
	int n,i,j,k,x;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		b[i]=a[i];
	}
	sort(b+1,b+n+1);
	for(i=1;i<=n;i++)
	{
		x=0x3f3f3f3f;
		for(j=1;j<=n;j++)
		{
			x=min(x,dp[i-1][j]);
			dp[i][j]=abs(a[i]-b[j])+x;
		}
	}
	x=0x3f3f3f3f;
	for(i=1;i<=n;i++)
		x=min(x,dp[n][i]);
	printf("%d\n",x);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值