Contests abc228 submissions

  • Time Limit: 2 sec / Memory Limit: 1024 MB
  • Score : 100 points

atcoder
atcoder
Input

  • Input is given from Standard Input in the following format:
S T X

Output

If the light is on at 30 minutes past X o'clock, print Yes; otherwise, print No.

Sample Input 1

7 20 12

Sample Output 1

Yes
The light is on between 7 o'clock and 20 o'clock. At 30 minutes past 12 o'clock, it is on, so we print Yes.

Sample Input 2

20 7 12

Sample Output 2

No
The light is on between 0 o'clock and 7 o'clock, and between 20 o'clock and 0 o'clock (on the next day). At 30 minutes past 12 o'clock, it is off, so we print No.

Sample Input 3

23 0 23

Sample Output 3

Yes

WA:

/*    ----- atcoder 11.20 --------
----------- A.on and off --------------
*/
#include <bits/stdc++.h>
using namespace std;
int main()
{
    std::ios_base::sync_with_stdio(false);
    int s, t, a;
    cin >> s >> t >> a;
    int res;
    if(s <= t)
    {
        res = t - s;
    }
    else
    {
        if(t == 0)
            res = 48 - s + t;
        else
            res = 24 - s + t;
    }
    //cout << res << endl;
    if(res > a)
        cout << "Yes" << endl;
    else
        cout << "No" << endl;
    return 0;
}

AC:

#include <bits/stdc++.h>
using namespace std;
int main() {
  double s, t, x;
  cin >> s >> t >> x;
  x += 0.5;
  string ans = "Yes";
  if(s < t) {
    if(x < s || x > t) ans = "No";
  }
  else {
    if(x < s && x > t) ans = "No";
  }    
  cout << ans << endl;
}

链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值