FatMouse and Cheese --- 记忆化搜索

该博客介绍了如何使用记忆化搜索算法解决一个最优化问题——胖鼠在有限步数内吃到最多奶酪。胖鼠从(0,0)位置开始,每次可以最多走k步,并且必须前往奶酪更多的位置。问题要求计算在被猫抓住前胖鼠能获得的最大奶酪数量。博主给出了问题的输入输出格式、思路解析以及C++代码实现,通过记忆化搜索来存储每个位置的最大价值,从而求解答案。
摘要由CSDN通过智能技术生成

**

FatMouse and Cheese

**
题目:
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:
从(0,0)开始走,每次最多走k步,下一个位置比现在奶酪多(价值大),获取价值,每次只能水平或垂直走,问最大能得到的价值。

思路:
记忆化搜索上下左右,存最大价值

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int to[4][2]={0,1,0,-1,1,0,-1,0};
int n,k,a,b,z,map[1100][1100],dp[1100][1100];
int dfs(int x,int y)
{
    if(dp[x][y]>0)
        return dp[x][y];//dp已走过
    else
    {
        int maxx=0;//四周的最大和
        int sum;//当前和
        int tx,ty;
        for(int i=0;i<4;i++)
        {
            for(int j=1;j<=k;j++)
            {
                tx=x+(to[i][0])*j;
                ty=y+(to[i][1])*j;
                if(tx>=0&&ty>=0&&tx<n&&ty<n&&map[tx][ty]>map[x][y])
                {

                    sum=dfs(tx,ty);
                maxx=max(sum,maxx);
            }
        }
    }
    dp[x][y]=maxx+map[x][y];//回溯到m,n时的最大和(从大到小)
    return dp[x][y];
}
}
int main()
{
    while(~scanf("%d%d",&n,&k)&&n!=-1&&k!=-1)
    {
        memset(map,0,sizeof(map));
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d%",&map[i][j]);
            }
        }
        dfs(0,0);
        printf("%d\n",dfs(0,0));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值