带运算符号的最大子序列

目录

问题大意:

样例输入:

样例输出:

解决方案:


问题描述:

 题目:

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.


问题大意:

该问题输入一个数n,接下来有n行数据,第一个数输入m,后面有m个数据,m个数据组成序列,求一个子序列所得的最大值,并且求出子序列的开始位置(头),结束位置(尾)


样例输入:

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

样例输出:

Sample Output

Case 1:

14 1 4 

Case 2:

7 1 6

 

解决方案:

  1.        
    #include "stdio.h"
    #include "string.h"
    #include "algorithm"
    using namespace std;
    int a[101000];
    int main ()
    {
    	int t,i,k,n,j=0;
    	int s,g;
    	scanf("%d",&t);
    	while(t--)
    	{
    		j++;
    		int intf=-999999;
    		int sum=0;
    		memset(a,0,sizeof(a));
    		scanf("%d",&n);
    		for(i=1; i<=n; i++)
    			scanf("%d",&a[i]);
    		int head=1;//记录头部 
    		for(i=1; i<=n; i++)
    		{
    			sum=sum+a[i];
    			 // 依次求和 
    			 //如果和大于0,且再向后加数的时候比前一个和大 ;   
    			 //更新结束位置(尾部);  
    			if(sum>intf)   
    			{
    				intf=sum;     
    				s=head;
    				g=i;//记录尾部; 
    			}     
    			if(sum<0)
    			{
    				sum=0;
    				head=i+1;
    			}
    			// 和小于0
    			// 更新头部; 
    		}
    		printf("Case %d:\n",j);
    		printf("%d %d %d\n",intf,s,g);
    		if(t) 
    		printf("\n");
    	}
    	return 0;
    }

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值