UJN_1682 【C++ 字符串】替换字符串中的字符

//
Problem C: 【C++ 字符串】替换字符串中的字符
Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 1003  Solved: 537
[Submit][Status][Web Board]
Description
Write a program to input several strings from the keyboard and replace each space in these string with the character '@'.
Input
输入有多行,第一行输入一个整数N,后面N行每行输入一个字符串,以‘#’为定界符表示字符串结束
Output
输出有N行,每行输出一个替换字符后的字符串

Sample Input
3
A cat#
a b c#
a   #
Sample Output
A@cat
a@b@c
a@@@
HINT
注意:输入N后和每个字符串后的回车符的处理

//
#include<bits/stdc++.h>
using namespace std;

int main()
{
    string s; int n;

    while( cin>>n )
    {
        cin.get();
        while( n-- )
        {
            getline( cin,s );
            for( auto i:s )
            	if( i=='#' )		break;
                else if( i==' ' ) 	cout<<'@';
                else            	cout<<i;
            cout<<endl;
        }
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这题AC再睡.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值