【Let the Balloon Rise 「map」】

程序需要处理多个测试用例,每个用例包含不同颜色的气球数量。对每个用例,读取并统计每种颜色的气球,找到出现次数最多的颜色并输出。当输入的气球总数为0时,表示结束。示例中,红色和粉色分别是两个测试用例中最受欢迎的颜色。
摘要由CSDN通过智能技术生成

【问题描述】

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

【输入形式】

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

【输出形式】

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

【样例输入】

5

green

red

blue

red

red

3

pink

orange

pink

0
【样例输出】

red

pink

【样例说明】
【评分标准】

代码如下:

#include<bits/stdc++.h>

using namespace std;

int main()
{
    map<string, int> m;
    int t;
    string color;
    cin >> t;
    while (t)
    {
        while (t--)
        {
            cin >> color;
            m[color]++;
        }
        int maxn = 0;
        string s;
        for (auto it = m.begin(); it != m.end(); ++it)
        {
            if (it->second > maxn)
            {
                maxn = it->second;
                s = it->first;
            }
        }

        cout << s << endl;
        m.clear();
        cin >> t;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

武帝为此

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值