HDU 1789 题解

Problem:

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score。

Input:

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases.。T test cases follow。
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework。Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores。

Output:

For each test case, you should output the smallest total reduced score, one line per test case。

Sample Input:

请输入作业数量:3
请输入这个作业的分数和截至日期:3 1
请输入这个作业的分数和截至日期:2 1
请输入这个作业的分数和截至日期:1 2

Sample Output:

损失的最小分数为:2

思路:

首先对分数从大到小排序,若分数相同,则截止日期小的排在前面,做完一门作业时其它作业的截至日期都要减一。在我的代码中,首先输入用例,我用了一个结构体Attribute来定义作业,每个结构体的属性有score,data两个,然后通过sort进行排序,按照分数从大到小排序的同时,将分数相同的作业截至日期按从小到大排序,最先写完,再用min记录失去的分数,此时min为损失的最小的分数。

代码:

#include <iostream> 
#include <vector>   
#include <algorithm> 

using namespace std;
const int N = 1000;

// 定义作业属性,包含分数和截止日期
struct Attribute {
    int score; // 分数
    int data; // 截至日期
}HomeWork[N];

// 按照作业分数从大到小排序的同时,将分数相同的作业按截至日期从小到大排序
bool compare(const Attribute& a, const Attribute& b) {
    if (a.score == b.score) {
        return a.data < b.data; // 如果分数相同,则按照截至日期从小到大排序
    }
    return a.score > b.score; // 否则按照分数从大到小排序
}

int main() {
    int n;
    cout << "请输入作业的数量:";
    cin >> n;
    int min = 0; // 初始化损失的最小分数为0

    for (int i = 0; i < n; i++) {
        cout << "请输入这个作业的分数和截至日期:";
        cin >> HomeWork[i].score >> HomeWork[i].data; // 输入每份作业的属性
    }
    sort(HomeWork, HomeWork + n, compare); // 对作业进行排序

    for (int i = 0; i < n; i++) {
        if (HomeWork[i].data <= 0) { // 如果作业截至时间已过,则min加上此作业的分数
            min += HomeWork[i].score;
            continue;
        }
        for (int x = i + 1; x < n; x++) { // 做完当前作业后,未完成的作业截至时间缩短
            HomeWork[x].data--;
        }
    }

    cout << "损失的最小分数为:" << min << endl;

    return 0;
}

  • 5
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值