HDU 1548 A strange lift

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

题意有一个电梯,只有“上”键和"下"键,每一层会有对应的数字,你按上,就会往上走这个数字所对应得层数,同理,按下,就会往下走,但是往上不会超过N层,往下,不会低于一层,所以当你按向下的键后,所要下的层数低于一层的时候,这个是不合法的。求你到达目的地,所按的最少的次数。第一个数是楼的总层数,后面的俩数一个是起点,一个是终点,接下来的一列数是每个楼层对应的数,如果不能达到,输出-1

思路因为在每一步们都要把所有能到的地方试完,所以用广搜

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;


struct floor
{
  int k;
  int num;
}f[205];
queue<int>q;
int n,a,b,t;


int bfs(int a)
{
    while(!q.empty())
     q.pop();
  int  dian,Dian;
  int next[2]={1,-1};
  int i;
   q.push(a);
  while(!q.empty())
  {
     dian=q.front();
     q.pop();
     for(i=0;i<2;i++)
     {
       Dian=dian+f[dian].k*next[i];
       if(Dian==b)
       {
          f[Dian].num=f[dian].num+1;
          t=1;
          return 1;
       }
       if(Dian<=n &&Dian>0 )
       {
         f[Dian].num=f[dian].num+1;
       
         q.push(Dian);
       }
     }


  }
}


int main()
{
  while(scanf("%d",&n) &&n)
  {
    
    int i;
    cin>>a>>b;
    for(i=1;i<=n;i++)
    {
        cin>>f[i].k;
        f[i].num=0;
    }
    if(a==b)
    {
        cout<<"0"<<endl;
        continue;
    }


    t=0;
    memset(book,0,sizeof(book));
    bfs(a);
    if(t)
      cout<<f[b].num<<endl;
    else
      cout<<"-1"<<endl;




  }
}
  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值