Matrix (二分匹配)

     Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

    Your task is to give out the minimum times of deleting all the '1' in the matrix.
Input
    There are several test cases.

    The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
    The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

    n=0 indicate the end of input.
Output
    For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
Sample Input

    3 3
    0 0 0
    1 0 1
    0 1 0
    0

Sample Output

    2

题意:给你一个0,1矩阵,让你每次可以将一行或者一列的把1变成0,求最少几次可以让所有的1都变成0。

分析:二分匹配题,将矩阵中是1的格子的x和y坐标记录下来,然后再求最大匹配数即可。

#include<stdio.h>
#include<string.h>
int m,n,e[110][110],match[110],book[110];
int dfs(int u)
{
	int i;
	for(i = 1; i <= m; i ++)
	{
		if(book[i] == 0 && e[u][i] == 1)
		{
			book[i] = 1;
			if(match[i] == 0 || dfs(match[i]))
			{
				match[i] = u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,k,sum;
	while(scanf("%d",&n), n != 0)
	{
		scanf("%d",&m);
		sum = 0;
		memset(e,0,sizeof(e));
		memset(match,0,sizeof(match));
		for(i = 1; i <= n; i ++)
			for(j = 1; j <= m; j ++)
			{
				scanf("%d",&k);
				if(k == 1)
					e[i][j] = 1;
			}
		for(i = 1; i <= n; i ++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum ++;
		}
		printf("%d\n",sum);	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值