POJ--3579--查找第k大的值

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

常规思路一超时间:(超时)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const long long MAX=10000+1;
int n;
long long a[MAX],b[MAX/2*MAX];//数组极容易溢出 
int main(){
	while(scanf("%d",&n)!=EOF){
		long long cnt=0; 
		for(int i=0;i<n;i++)
			cin>>a[i];
		for(int i=0;i<n;i++)
			for(int j=i+1;j<n;j++)//这里已经超时!!!O(N^2) 
				b[cnt++]=fabs((double)(a[j]-a[i]));
		//新序列的长度是C(n,2),即为cnt; 
		sort(b,b+cnt);//O(log(n))
		if(cnt%2==0)
			cout<<b[cnt/2-1]<<endl;
		else
			cout<<b[cnt/2]<<endl; 
	} 
} 

思路二:具体见代码注释即可;

 

StatusAccepted
Time563ms
Memory224kB
Length756
LangC++
Submitted2020-02-01 15:30:24
Shared 
RemoteRunId21289534
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1111111;
int n;
int x[maxn];
long long m;
bool C(int mid){
    long long cnt=0;
    for(int i=0;i<n;i++)
        cnt+=x+n-lower_bound(x+i+1, x+n, x[i]+mid);
    //lower_bound返回第一个大于等于xi+mid值的下标,原数列在其后面的都比xi+mid大
    //cnt计算所有差值比mid大的原数列组合个数
    return cnt<=m/2;      //等于号是因为,cnt计算的是比mid大的个数
}
int main() {
    while(~scanf("%d", &n)){
        for(int i=0;i<n;i++)
            scanf("%d",&x[i]);
        sort(x,x+n);
        m = n*(n-1)/2;      //新数列的个数就是C_N_2(组合数),N是原数列的个数
        int L=0,R=*max_element(x,x+n); //r为最大元素
        while(R-L>1){
            int mid=(L+R)/2;
            if(C(mid)) 
				R=mid;
            else 
				L=mid;
        }
        printf("%d\n",L);
 
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值