HDU NO.4324 Triangle LOVE(拓扑排序)

4 篇文章 0 订阅

题意:

如果A爱B,那么B就一定不爱A  --!.

大致意思是,在图中能不能找到三角环。

原题描述:

Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world! 
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A. 
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”. 
 

Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases. 
For each case, the first line contains one integer N (0 < N <= 2000). 
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A  i,j = 1 means i-th people loves j-th people, otherwise A  i,j = 0. 
It is guaranteed that the given relationship is a tournament, that is, A  i,i= 0, A  i,j ≠ A  j,i(1<=i, j<=n,i≠j).
 

Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”. 
Take the sample output for more details. 
 

Sample Input

    
    
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output

    
    
Case #1: Yes Case #2: No
 

思路:

可以吧图中是“1”的坐标构成有向图,然后拓扑排序,如果结果没有拓扑序列即有环也就是存在三角恋 --!

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<set>

using namespace std;

#define X first
#define Y second

const int INF = 0x3f3f3f3f;
const int MAX = 3000;
int head[MAX], indegree[MAX], que[MAX];
int top, n;

struct node{
    int to, w, next;
}edge[MAX * MAX];

void add_edge(int u, int v)
{
    edge[top].to = v;
    edge[top].next = head[u];
    head[u] = top++;
}

void init(){
    top = 0;
    memset(head, -1, sizeof(head));
    memset(indegree, 0, sizeof(indegree));
}

bool Topsort(){
    int iq = 0;
    for(int i = 0; i < n; i++)
        if(indegree[i] == 0)
            que[iq++] = i;
    for(int i = 0; i < iq; i++){
        for(int j = head[que[i]]; j != -1; j = edge[j].next){
            indegree[edge[j].to]--;
            if(indegree[edge[j].to] == 0)
                que[iq++] = edge[j].to;
        }
    }
    if(iq < n - 1)
        return true;
    else
        return false;
}

int main(){
    int t, cns = 1;
    scanf("%d", &t);
    while(t--){
        init();
        scanf("%d", &n);
        char arr[n][n];
        for(int i = 0; i < n; i++){
            scanf("%s", &arr[i]);
            for(int j = 0; j < n; j++){
                if(arr[i][j] == '1'){
                    add_edge(i, j);
                    indegree[j]++;
                }
            }
        }
        int res = Topsort();
        if(res)
            printf("Case #%d: Yes\n", cns++);
        else
            printf("Case #%d: No\n", cns++);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值