九度OJ 题目1437:To Fill or Not to Fill

时间限制:1 秒  内存限制:128 兆

题目描述:

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入:

For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

输出:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
50 1300 12 2
7.10 0
7.00 600
样例输出:
749.17
The maximum travel distance = 1200.00
来源:
2012年浙江大学计算机及软件工程研究生机试真题


代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct price
{
    double p;
    int d;
};
int comp(const price a, const price b)
{
    return a.d<b.d;
}
int main()
{
    int Cmax,D,Davg,N;
    while(cin>>Cmax>>D>>Davg>>N&&Cmax<=100&&D<=30000&&Davg<=20&&N<=500)
    {
        double dmax = Cmax*Davg;//最大可走距离 
        struct price price[N];
        for(int i=0;i<N;i++) cin>>price[i].p>>price[i].d;
        sort(price,price+N,comp);//收费站按距离排序 
        double alprice=0;//花钱数
        double dis=0; //剩余油可行驶距离 
        int i =0,next,flag;
        if(N==0||price[0].d!=0)//起始点没有加油站时33
        {
            printf("%s %.2lf\n","The maximum travel distance =",0);
            continue;
        } 
 
        while(i<N)
        {
            int j=1;
            flag = 0;
            if(i==N-1&&D-price[i].d>dmax)//开到最后一个加油站  到不了 
            {
                printf("%s %.2lf\n","The maximum travel distance =",price[N-1].d+dmax);
                flag=4;
                break;
            }
            else if(i==N-1) //开到最后一个加油站 能到 
            {
                alprice+=price[i].p*(D-price[i].d-dis);
                break;
            }
 
            if(price[j+i].d-price[i].d>dmax)//到不了下一个加油站 
            {
                printf("%s %.2lf\n","The maximum travel distance =",price[i].d+dmax);
                flag=4;
                break;
            }
            double minprice = price[j+i].p;
            while(price[j+i].d-price[i].d<=dmax&&j+i<N)
            {
                if(price[j+i].p<=price[i].p) //flag 1. 最大距离以内有更便宜的 
                {
                    alprice+=price[i].p*(price[j+i].d-price[i].d-dis);
                    next=j;
                    flag=1;
                    dis=0;
                    break;
                }
                else if(price[j+i].p<=minprice) //flag 2. 选择次便宜的加油站 
                {
                    minprice = price[j+i].p;next = j;flag=2;
                }
                   j++;
            }
            if(flag==2&&(D-price[i].d<dmax))  // 离终点不足最大距离且无更便宜的加油站时, 直接开到终点。
            {
                alprice+=price[i].p*(D-price[i].d-dis);
                flag=3;
                dis=0;
                break;
            }
            else if(flag==2) //否则加满油,前往次便宜加油站
            {
                alprice += price[i].p*(dmax-dis);
                dis = dmax-(price[next+i].d-price[i].d);
            }
         
            i+=next;
        }
        if(flag!=4) printf("%.2lf\n",alprice/Davg);
         
    }
    return 0;
}
 
/**************************************************************
    Problem: 1437
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1524 kb
****************************************************************/

参考测试数据:

50 1300 12 8
7.10 0
7.00 150
7.50 400
8.00 600
7.20 900
7.30 1000
6.00 1250
6.85 1280
-------------------
正确答案为   767.50



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值