1010. Zipper

1010. Zipper

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. For example, consider forming "tcraete" from "cat" and "tree": String A: cat String B: tree String C: tcraete As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": String A: cat String B: tree String C: catrtee Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print: Data set n: yes if the third string can be formed from the first two, or Data set n: no if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no
 
/从后面开始递归,第三个字符串的最后一位要么在第一个字符串上要么在第二个上,否则不存在
 
#include <iostream>
#include <string>

using namespace std;

string first, second, third;
bool dp(int f, int s, int t)
{
	if (t < 0)
		return true;
	if (f >= 0 && first[f] == third[t] && dp(f - 1, s, t - 1))
		return true;
	if (s >= 0 && second[s] == third[t] && dp(f, s - 1, t - 1))
		return true;
	return false;
}
int main()
{
	int n;
	cin >> n;
	
	int f, s, t;
	for (int index = 1; index <= n; index++)
	{
		cin >> first >> second >> third;
		f = first.size() - 1;
		s = second.size() - 1;
		t = third.size() - 1;
		
		if (dp(f, s, t))
				cout<<"Data set "<< index <<": yes"<<endl;
		else
			cout<<"Data set "<< index <<": no"<<endl;
	}
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值