hdoj5288OO’s Sequence

OO’s Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3569    Accepted Submission(s): 1301


Problem Description
OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy a i mod a j=0,now OO want to know
i=1nj=inf(i,j) mod 109+7.

 

Input
There are multiple test cases. Please process till EOF.
In each test case: 
First line: an integer n(n<=10^5) indicating the size of array
Second line:contain n numbers a i(0<a i<=10000)
 

Output
For each tests: ouput a line contain a number ans.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
23
 

Author
FZUACM
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5774  5773  5772  5771  5770 

定义两个数组L[i], R[i]L[i],R[i],表示第ii数左侧和右侧最接近它且值是a[i]a[i]因子的数字的位置,那么第ii个数能贡献的答案就是(R[i]-i)*(i-L[i])(R[i]i)(iL[i]),因此每个数字xx都去枚举它的因子yy,然后左右找到一个值是yy且最接近xx的数,然后用他的位置更新一下L,RL,R数组。时间复杂度O(n\sqrt{a})O(na)

/* ***********************************************
Author       : ryc
Created Time : 2016-07-30 Saturday
File Name    : E:\acmcode\hdoj\5288.cpp
LANGUAGE     : c++
Copyright 2016 ryc All Rights Reserved
************************************************ */
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#define MOD 1000000007
using namespace std;
const int maxn=1e5+10;
int num[maxn],vis[maxn];
int l[maxn],r[maxn];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        int cnt=0;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;++i){
            scanf("%d",&num[i]);
            cnt=max(cnt,num[i]);
            l[i]=0;r[i]=n+1;
            for(int j=num[i];j<=cnt;j+=num[i]){
                if(vis[j]&&r[vis[j]]>i)r[vis[j]]=i;
            }vis[num[i]]=i;
        }cnt=0;
        memset(vis,0,sizeof(vis));
        for(int i=n;i>=1;--i){
            cnt=max(num[i],cnt);
            for(int j=num[i];j<=cnt;j+=num[i]){
                if(vis[j]&&l[vis[j]]<i)l[vis[j]]=i;
            }vis[num[i]]=i;
        }
        long long ans=0;
        for(int i=1;i<=n;++i){
            ans=(ans+(i-l[i])*(r[i]-i)%MOD)%MOD;
           // printf("%lld\n",ans);
        }
        printf("%lld\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值