[背包问题][第三阶段-初见dp][HDU-2504]Bone Collector

81 篇文章 0 订阅
35 篇文章 0 订阅

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		
		int T = in.nextInt();
		while(T>0){
			int N = in.nextInt();
			int V = in.nextInt();
			int[] value = new int[N+1];
			int[] volume = new int[N+1];
			int[][] sum = new int[N+10][V+10];
			int i,j;
			for(i=1;i<N+1;i++)
				value[i]=in.nextInt();
			for(i=1;i<N+1;i++)
				volume[i]=in.nextInt();
			
		   for(j=0;j<=V;j++)
			   for(i=1;i<=N;i++){
				   if(j<volume[i]){
					   sum[i][j]=sum[i-1][j];
					   continue;
				   }else if(sum[i-1][j-volume[i]]+value[i]>sum[i-1][j])
					   sum[i][j]=sum[i-1][j-volume[i]]+value[i];
				   else
					   sum[i][j]=sum[i-1][j];
			   }
			System.out.println(sum[N][V]);
			T--;
		}
	}
}

一定要从0开始检索

因为有下面这组变态的数据

1
2     0
20   1
0     1

答案是: 20  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值