[暖手][学习阶段-各路杂题][HDU-1028]Ignatius and the Princess III

35 篇文章 0 订阅
5 篇文章 0 订阅

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 

最早用递归做的,闭着眼都知道超时了。

然后用dp做 A了一次 但是感觉很丑

在网上找到大神的办法 贴在下面

题解:

画出解答树,每个结点有两个值(暂时叫左值和右值)不断划分,原则是将大数化为小数,左值大于右值,结点左值的子树的右值大于等于结点的右值。

n = 5、6、7、8时解答树如下:


由n=8的解答树,可知该解答树有4个子树记作A[8][1]、A[8][2]、A[8][3]、A[8][4]

A[8][1] = A[7][1] + A[7][2] + A[7][3] + 1.

A[8][2] = A[6][2] + A[6][3] + 1

A[8][3] = A[5][3] + 1

A[8][4] = A[4][4] + 1

记A[8][0]为n=8的总结点,则A[8][0] = A[8][1] + A[8][2] + A[8][3] + A[8][4] + 1

ps:也可以用DFS


import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		int n, i, j, k;  
		int[][] A = new int[121][70]; 
	    for (k=1; k<=120; k++)  
	    {  
	        A[k][0] = 1;  
	        for (i=1; i<=k/2; i++)  
	        {  
	            for (j=i; j<=(k-i)/2; j++)  
	                A[k][i] += A[k-i][j];  
	            A[k][i] += 1;  
	            A[k][0] += A[k][i];  
	        }  
	    }  
		while(in.hasNext()){
			n= in.nextInt();
			System.out.println(A[n][0]);
		}
		}
	}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值