[kuangbin带你飞]专题4 最短路 A - Til the Cows Come Home POJ - 2387

题目:

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 61857 Accepted: 20985

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题意:一个无向带权图有n个顶点,T条边。顶点序号从1到n。求序号为1的点到序号为n的顶点的最短路。

思路:单源最短路径。迪杰斯特拉算法模板。链式前向星存图。

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<stack>

typedef long long ll;

using namespace std;

int head[10010];
struct{
	int to;
	int w;
	int next;
}mapp[10010];

int minlen[10010];
bool vis[10010];

struct node{
	int n;
	int len;
	
	node(const int nn,const int lenn){
		n = nn;
		len = lenn;
	}
	
	friend bool operator< (node f1, node f2){
		if(f1.len != f2.len)
			return f1.len > f2.len;
        return f1.n > f2.n; 
    }
};

int main(){
	ios::sync_with_stdio(false);
	memset(head,0,sizeof(head));
	memset(mapp,0,sizeof(mapp));
	memset(vis,0,sizeof(vis));
	
	int t,n;
	cin>>t>>n;
	
	for(int i = 1 ; i<=2*t ; i++){
		int a,b,len;
		cin>>a>>b>>len;
		
		mapp[i].to = b;
		mapp[i].w = len;
		mapp[i].next = head[a];
		head[a] = i;
		
		i++;
		mapp[i].to = a;
		mapp[i].w = len;
		mapp[i].next = head[b];
		head[b] = i;
	} 
	
	priority_queue<node> q;
	memset(minlen,-1,sizeof(minlen));
	minlen[1] = 0;
	q.push(node(1,0));
	
	while (!q.empty()){
		node temp = q.top() ; q.pop();
		vis[temp.n] = 1;
		
		if(minlen[temp.n]!=-1 && minlen[temp.n]<temp.len)
			continue;
		
		for(int i = head[temp.n] ; i!=0 ; i = mapp[i].next){
			int nxt = mapp[i].to;
			if(!vis[nxt]){
				if(minlen[nxt] == -1){
					minlen[nxt] = minlen[temp.n]+mapp[i].w;
					q.push(node(nxt,minlen[nxt]));
				}
				else if(minlen[nxt] > minlen[temp.n]+mapp[i].w){
					minlen[nxt] = minlen[temp.n]+mapp[i].w;
					q.push(node(nxt,minlen[nxt]));
				}
			}
		}
	}

	cout<<minlen[n]<<endl;
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值