uva 10325 容斥原理


The Sports Association of Bangladesh is in great problem with their latest lottery 'Jodi laiga Jai'. There are so many participants this time that they cannot manage all the numbers. In an urgent meeting they have decided that they will ignore some numbers. But how they will choose those unlucky numbers!! Mr. NondoDulal who is very interested about historic problems proposed a scheme to get free from this problem.

You may be interested to know how he has got this scheme. Recently he has read the Joseph's problem.

The Problem

There are N tickets which are numbered from 1 to N. Mr. Nondo will choose M random numbers and then he will select those numbers which is divisible by at least one of those M numbers. The numbers which are not divisible by any of those M numbers will be considered for the lottery.

As you know each number is divisible by 1. So Mr. Nondo will never select 1 as one of those M numbers. Now given N,M and M random numbers, you have to find out the number of tickets which will be considered for the lottery.

The Input

Each input set starts with two Integers N (10<=N<2^31) and M (1<=M<=15). The next line will contain M positive integers each of which is not greater than N. Input is terminated by EOF.

The Output

Just print in a line out of N tickets how many will be considered for the lottery.

Sample Input

10 2
2 3
20 2
2 4

Sample Output

3
10
 
先求出不符合的数量 sum :
举例:m = 5
对 m 个数字进行组合,用二进制枚举所有情况,求每组组合数的最小公倍数。
flag 表示组合数的数量
if(flag%2==0) sum -= N(n,g); //偶数个
else sum+=N(n,g);  //奇数个
 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long data[20];
long long gcd(long long a,long long b){
    if(b==0) return a;
    return gcd(b,a%b);
}
long long lcm(long long a,long long b){
    return (long long)a/gcd(a,b)*b;
}
long long N(long long n,long long x){
    return n/x;
}
int main(){
    long long n,m;
    long long sum,g,flag;
    while(scanf("%lld%lld",&n,&m)!=EOF){
        sum = 0;
        for(int i=0;i<m;i++) {
            scanf("%d",&data[i]);
        }
        sum = 0;
        for(int i=1;i<(1<<m);i++) {
            g = 1;
            flag = 0;
            for(int j=0;j<m;j++) {
                if((1<<j)&i) {
                    g = lcm(g,data[j]);
                    if(g>n) break;
                    flag++;
                }
            }
            if(flag%2==0) sum -= N(n,g);
            else sum+=N(n,g);
        }
        printf("%lld\n",n-sum);
    }
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值