hdu 4034 Graph (floyd)

Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 1365    Accepted Submission(s): 687


Problem Description
Everyone knows how to calculate the shortest path in a directed graph. In fact, the opposite problem is also easy. Given the length of shortest path between each pair of vertexes, can you find the original graph?
 

Input
The first line is the test case number T (T ≤ 100).
First line of each case is an integer N (1 ≤ N ≤ 100), the number of vertexes.
Following N lines each contains N integers. All these integers are less than 1000000.
The jth integer of ith line is the shortest path from vertex i to j.
The ith element of ith line is always 0. Other elements are all positive.
 

Output
For each case, you should output “Case k: ” first, where k indicates the case number and counts from one. Then one integer, the minimum possible edge number in original graph. Output “impossible” if such graph doesn't exist.

 

Sample Input
  
  
3 3 0 1 1 1 0 1 1 1 0 3 0 1 3 4 0 2 7 3 0 3 0 1 4 1 0 2 4 2 0
 

Sample Output
  
  
Case 1: 6 Case 2: 4 Case 3: impossible
 

Source
 

Recommend
lcy
 

解题报告:

从给定的图中选择边,如果一条边等于其余两边之和,把该边标记为一个很大的数(即删除)

如果一条边比另外两条边大,则输出impossible;

代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 0x7ffffff;
int n,mp[105][105];

void floyd()
{
	int sum=n*n-n;
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
			{
				if(mp[i][j] == mp[i][k]+mp[k][j] &&(k!=i&&i!=j)&&k!=j)
				{
					sum--;
					mp[i][j]=maxn;
				}
				else if(mp[i][j]!=maxn&&mp[i][j] > mp[i][k]+mp[k][j]&&k!=i&&i!=j&&k!=j)
				{
					printf("impossible\n");
					return ;
				}
			}
	printf("%d\n",sum);
}
int main()
{
	int T,ncase=0;
	scanf("%d",&T);
	while(T--)
	{
		
		memset(mp,127,sizeof(mp));
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				scanf("%d",&mp[i][j]);
		printf("Case %d: ",++ncase);
		floyd();
	}	
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值