素数筛(hdu 2710)

素数

枚举因子法

 

<strong>bool judeg(int n)
{
    if(n==1)  return false;
    for(int i=2; i*i<=n; i++)
    {
        if(n%i==0)  return false;
    }
    return true;
}</strong>

 

更准确的说应该是判断某个数是不是素数,如果做素数筛用,复杂度会很高

 

普通素数筛

 

   

 1.把1~n列出来

 2.去掉不是特殊的1

 3.从小到大,枚举每一个没有删掉的数字i

 4.把i的2倍,3倍,4倍,…,删掉

 5.剩下的没被删掉的都是素数

<strong>const int N=1000005;
bool prime[N];
void init()
{
    memset(prime,false,sizeof(prime));
    prime[1]=true;
    for(int i=2; i<N; i++)
    {
        if(prime[i]==false)
        {
            for(int j=i+i; j<N; j=j+i)    //素数的倍数全部筛去
            {
                prime[j]=true;
            }
        }
    }
}</strong>

复杂度为O(nloglogn),缺点是有的合数被删除了多次,那么如何保证每个合数只被删除一次呢?

 

素数的线性筛

 

1.列出1~n

2.删除特殊的1

3.2开始枚举数i,若没有被删掉,则加入素数表中

4.枚举素数表中的每一个素数j,并把i*j的结果从表里删去,直到枚举到j能整除i

const int N=100000005;
bool prime[N];
int a[N],k=0;      //a[N]存素数
void init()
{
    memset(prime,false,sizeof(prime));
    prime[1]=true;
    for(int i=2; i<N; i++)
    {
        if(prime[i]==false)
        {
            a[k++]=i;
        }
        for(int j=0; j<k && a[j]*i<N; j++)     //枚举素数表
        {
            prime[a[j]*i]=true;
            if(i%a[j]==0)   break;           //若该数是某个素数的倍数,则退出循环
        }
    }
}

 

if(i%a[j]==0)   break; 

这是一个很简单有效的优化,原理基于“尽量只筛一次”。 

     在这里提出“最小质因子”的概念,然后规定每个合数都只被它的最小质因子筛出————这个定义很好地契

合了“尽可能只筛一次”的想法。

     回到问题,当前如果出现"i%a[j]==0"的情况,由于枚举素数a[j]是从小到大的,那么可以说明a[j]是i的最小质因子。

     此时如果不终止循环,那么a[j+1],a[j+2]...会与i相乘得到其他的合数然后筛掉,但是该合数的最小质因子不是

该素数,然而我们使用了这个素数将其筛掉,这样做会使得一个数被筛多次,降低了效率。

例如 20应该由2 * 10筛掉,而不是被4 * 5筛掉(素数2<素数5)。

     即每一个素数都只被记录一次,每一个合数都只会被一个唯一的最小质因子标记一次因此是O(n)线性复杂度。

 

 

一道最大素数的水题  hdu 2710

 

 

Max Factor

 

                                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                               Total Submission(s): 10212    Accepted Submission(s): 3292

 

 

Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

 

 

Input

* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

 

 

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

 

 

Sample Input

 

436384042

 

 

Sample Output

 

38

 

代码如下

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
int prime[20005];
void init()
{
    memset(prime,0,sizeof(prime));
    prime[1]=1;              //题中认为1也是素数
    for(int i=2; i<20005; i++)
    {
        if(prime[i]==0)
        {
            for(int j=i; j<20005; j=j+i)
            {
                prime[j]=i;              //数组里记录的是该数的最大质因子
            }
        }
    }
}
int main()
{
    int n;
    init();
    while(scanf("%d",&n)!=EOF)
    {
        int x=0,a,ans;
        while(n--)
        {
            scanf("%d",&a);
            if(prime[a]>x)
            {
                x=prime[a];
                ans=a;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值