HDU5533 Dancing Stars on Me(几何,思路)

Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input

The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following nlines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.

Output

For each test case, please output “YES” if the stars can form a regular polygon. Otherwise, output “NO” (both without quotes).

Sample Input

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0 

Sample Output

NO
YES
NO

思路

给你n个点,问这n个点能不能组成一个正n边形。题目保证一定是整数点,所以值存在正四变形这种情况。我们找到外接圆圆心,判断圆心距离其他点的长度是否相等即可,注意精度.

代码

#include <bits/stdc++.h>
using namespace std;
#define mem(a, b) memset(a, b, sizeof(a))
const int N = 1e2 + 10;
const double eps = 1e-5;
double x[N], y[N];
double get_dis(double x1, double y1, double x2, double y2)
{
    return (x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2);
}
int main()
{
    //freopen("in.txt", "r", stdin);
    int t, n;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d", &n);
        double rx = 0, ry = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%lf%lf", &x[i], &y[i]);
            rx += x[i], ry += y[i];
        }
        rx = rx / (n * 1.0);
        ry = ry / (n * 1.0);
        double dis = get_dis(rx, ry, x[0], y[0]);
        int flag = 1;
        for (int i = 1; i < n; i++)
        {
            if (fabs(get_dis(rx, ry, x[i], y[i]) - dis) >= eps)
            {
                flag = 0;
                break;
            }
        }
        puts(flag ? "YES" : "NO");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值